I am running Windows XP but Lake 6.1 will not run?

Make sure you are running Windows XP Service Pack 3. Lake 6.1 does not support SP1 or SP2.


Share this page