Konnekt, Impact Twin and Powercore: Windows XP SP3

Question

Does Konnekt, Impact Twin and Powercore work with Windows XP Service Pack 3?

Answer

Yes, both the Konnekt and PowerCore series of products are compatible with SP3. If you are using a Konnekt or FireWire-based PowerCore you should install this Microsoft hotfix


Share this page