PowerCore / Konnekt / Impact: Do they run under Windows 8 and 8.1?

Question

Can I run Konnekt / Impact Twin / PowerCore FireWire under Windows 8 and 8.1?

Answer

Microsoft lately released signed 1394 OHCI Legacy Drivers for Windows 8 and 8.1 which allow you to use our FireWire devices on this operating system.
You can download these drivers from here: http://support.microsoft.com/kb/2970191/ 


Share this page