PowerCore / Konnekt / Impact Twin with Apple Logic Pro / Express / Studio

Question

Is the PowerCore / Konnekt / Impact Twin platform compatible with Apple Logic Pro / Logic Express / Logic Studio?

Answer

Logic Pro 9 / Logic Express 9

The current PowerCore software package has successfully been tested with Logic 9 under Mac OS X 10.6.4.

The current Konnekt software package has successfully been tested with Logic 9 under Mac OS X 10.6.4.


 Logic Pro 8

The current PowerCore software package has successfully been tested with Logic Pro 8 under Mac OS X 10.4.10 and higher (including Leopard) under both Intel and PowerPC Macs.

The current Konnekt software package has successfully been tested with Logic Pro 8 under Mac OS X 10.4.10 and higher (including Leopard) under both Intel and PowerPC Macs.


Logic Pro 7

The PowerCore software is fully compatible with Logic 7. However in order to have the plug-ins pass the Logic AU Validation test under OS X 10.3 Panther, you need to use PowerCore driver version 1.9.6 or higher.

If you are using Mac OS X 10.4 Tiger, PowerCore 1.9.6 or higher is recommended.

The current Konnekt software package has successfully been tested with Logic Pro 7 under Mac OS X 10.4.10 under both Intel and PowerPC Macs.


Share this page