PowerCore: Old software versions

Question

Where can I find older software versions for the PowerCore?

Answer

Please use these links below.


Windows

Windows Vista / 7 (64 bit) - for PowerCore PCI mkII  / Unplugged / Compact / FireWire / X8 / 6000:

PowerCore 4.0.3

Windows XP / Vista (32 bit) - for PowerCore PCI mkII  / Unplugged / Compact / FireWire / X8 / 6000:

PowerCore 4.0.3 
PowerCore 3.2

Windows XP - for PowerCore Element / PCI / PCI mkII  / Unplugged / Compact / FireWire / X8:

PowerCore 3.1.1
PowerCore 3.1.0
PowerCore 3.0.2
PowerCore 2.2.1
PowerCore 1.9.6
PowerCore 1.9.3

Windows 98 SE / ME / 2000 - for PowerCore Element / PCI:

PowerCore 1.6.1
PowerCore 1.6.2


Mac OS

Mac OS X (32 & 64 bit) - for PowerCore PCI mkII / Unplugged / Compact / FireWire / X8 / 6000

PowerCore 4.0.5

Mac OS X (32 bit) - for PowerCore PCI mkII / Unplugged / Compact / FireWire / X8 / 6000

PowerCore 3.2

Mac OS X (32 bit) - for PowerCore Element / PCI / PCI mkII / Unplugged / Compact / FireWire / X8:

PowerCore 3.1.1
PowerCore 3.1.0
PowerCore 3.0.2
PowerCore 2.2.1
PowerCore 1.9.6
PowerCore 1.9.3

Mac OS 9 - for PowerCore Element / PCI:

PowerCore 1.6.1


Please note the following:

All support and quality assurance testing has been discontinued for the software versions above, and they are provided as-is.

The latest PowerCore software can be downloaded from this page.


Share this page