PowerCore: Supported operating systems

Question

Which operating systems are supported by the latest PowerCore software ?

Answer

Mac OSElement / PCIPCI MkIIUnplugged
CompactFireWireX86000Software
10.7 and higher--------
10.5 / 10.6 (32 & 64 bit Intel)-xxxxxxV4.4.1
10.5 (32 bit PPC / Intel)-xxxxxxV4.0.5
10.4-xxxxxxV3.2.0
10.4xxxxxx-V3.1.1
OS 9x------V1.6.1
WindowsElement / PCIPCI MkIIUnpluggedCompactFireWireX86000Software
Vista / 7 (64 bit)-xxxxxxV4.4.1
XP / Vista / 7 (32 bit)-xxxxxxV4.4.1
XP (32 bit)xxxxxx-V3.1.1
98 SE / ME / 2000x------V1.6.1

Some users report getting the PowerCore to work under Mac 10.7 and higher, although this is unsupported by us.


Share this page