PowerCore compatibility with EMU Ensoniq Paris Pro

Question

Does PowerCore work with the EMU Ensoniq Paris Pro System?

Answer

Yes, the PowerCore platform works with the EMU Paris HD recording system. You will need to have PowerCore driver version 1.6.1 installed in order for it to work.

Click here for PowerCore 1.6.1 for Windows.
Click here for PowerCore 1.6.1 for Mac OS 9.

Please note the following: 

  • PowerCore 1.6.1 is the last version confirmed to be working with Paris - newer versions of the PowerCore drivers have not been tested with it and aren't supported.
  • As only the PowerCore PCI and Element support Mac OS 9, it is not possible to use any other PowerCore types with the EMU Paris systems on Mac OS 9.
  • PowerCore 1.6.1 does not support Windows XP. If you wish to use the PowerCore with Paris we recommend you use Windows 2000.

Share this page