PowerCore v. 2 (and higher): compatibility with older PowerCores

Question

I have a PowerCore PCI / Element card, is PowerCore 2 (and higher) compatible with it ?

Answer

In short: yes.

What you get:

With PowerCore PCI / Element running PowerCore driver version 2 (and higher), you get the benefit on newer improved drivers and more efficient CPU and plug-in handling, in addition to the new GUI design.

What you don't get:

20 hours of demo time for each optional plug-in. Why not?

The above only works on 2nd generation PowerCores (all except PCI and Element).


Share this page