Updating Pro Tools plug-ins

Question

I have an older version of Master X3 / TC Tools and wish to update to the latest version. How can I do this?

Answer

It depends on which version you have:


If you already have Master X3 / TC Tools authorised on your iLok, you only need the download and run the latest installers which you can find on the links below:

Please note: this two versions use iLok authorisation exclusively. Please refer to this answer for more information about authorising the different ProTools plug-in versions.

For more information about Universal compatibility for Mac OS X, please refer to this answer.


The Master X3 / TC Tools versions below did not use iLok authorisation:

  • TC Master X3 1.x, 2.x or 3.x > TC Master X3 3.9
  • TC Tools 1.x, 2.x or 3.x > TC Tools 3.7

If you have one of these, the update to the latest version will cost $95 (ex VAT) and it is available from us directly. For more information, please get in touch with the TC Support Team and be sure to include your Master X3 / TC Tools serialnumber and iLok ID.


There are unfortunately no upgrades or crossgrades available for Master X5, MegaReverb, VoiceTools or TDM Works.


Share this page