Switch-6: Which products will it work with?


Which products will the Switch-6 work with?


At this time, the Switch-6 is only compatible with the VoiceLive 3 and the VoiceLive Touch 2 (firmware update is required). If more devices become compatible, this FAQ will be updated.

To update your units firmware, you will require our VoiceSupport application. Software and manual are located here: 

If you have any issues, please contact us using the link above.

Share this page