VoiceLive 2 Extreme Edition Firmware

Question

Does the 1.4 Firmware for VoiceLive 2 work on the VoiceLive 2 Extreme Edition?

Answer

No!

The hardware is different in the Extreme Edition, so loading 1.4 or 1.4.02 Firmware will fail and potentially "brick" your device.

Stick with the Firmware that came from the factory.

Future updates to VoiceLive 2 Firmware will be compatible with VoiceLive 2 Extreme Edition.


Share this page