VoiceSupport 2: not compatible with my Windows/Mac operating system?

Question

I can't seem to use the new VoiceSupport 2 and I suspect that this is due to my computer's operating system being too old. What can I do?

Answer

Yes, VoiceSupport 2 has the below minimum system requirements and some older operating systems may not be able to run VoiceSupport 2 correctly. These operating system are no longer being actively supported from Microsoft and Apple, which makes it difficult for us to verify that everything works across this many different platforms. In addition there are some non-trivial technical issues that make it very time-consuming to troubleshoot for unsupported OS’s.

Windows:

  • Vista (32 or 64 bit); Windows 7 (32 or 64 bit)
  • Windows 8 (32 or 64 bit)
  • Windows 10

Mac:

  • 10.9
  • 10.10
  • 10.11

For those users working with older, non-supported operating systems, the only solution is to continue using the original VoiceSupport (attached). 

You will be able to continue to use the original VoiceSupport for preset management, but please note that no new preset packs will appear on VoiceSupport, nor will the very latest firmware updates for you unit. Also, any links to the TC Helicon website will cease to work correctly.

 

The installers for the original VoiceSupport can be found attached to this post.

(voicesupport_1201_build38)  Windows

(voicesupport_1201_build38pkg)  Mac

 


Share this page